Notification delivery delay
Incident Report for Pushpad
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 21, 2018 - 13:57 CEST
Identified
There can be some small issues like processing delays due to maintenance.
Posted about 1 year ago. Jun 21, 2018 - 13:38 CEST
This incident affected: Service.