Performance issues
Incident Report for Pushpad
Resolved
In the last days we have performed load tests and monitored the performance: everything runs smoothly.
Posted about 1 year ago. May 10, 2018 - 22:09 CEST
Update
We are still monitoring the situation and working to improve performance: for example we have further reduced the number of inactive connections and increased the number of allowed connections.
Posted about 1 year ago. May 09, 2018 - 02:44 CEST
Monitoring
The configuration change that drops inactive connections to the frontend seems to have resolved the performance issues. Another problem in the load balancer was also identified and solved. Finally we have noticed very good performance during the last hours, even during traffic peaks. We will keep monitoring the situation just to make sure that the problem is completely solved.
Posted about 1 year ago. May 08, 2018 - 10:50 CEST
Identified
We have identified the problem. The slow responses in the last hours were caused by the load balancer: there was a very large number of inactive connections. At the moment we are still not sure about the origin of that connections, however we have made some configuration changes to mitigate the issue.
Posted about 1 year ago. May 07, 2018 - 23:24 CEST
Investigating
We are still investigating the slow responses reported in the previous days. Today we have made some changes to mitigate the high load on our servers, but this may not be enough. We need some more time in order to monitor and fix this problem completely.
Posted about 1 year ago. May 07, 2018 - 20:01 CEST
This incident affected: Service.